MCPcopy Create free account

hub / github.com/jcmturner/gokrb5 / functions

Functions1,776 in github.com/jcmturner/gokrb5

↓ 1 callersFunctionNewConfigFromReader
NewConfigFromReader creates a new Config struct from an io.Reader.
config/krb5conf.go:536
↓ 1 callersFunctionNewFromReader
NewFromReader creates a new Config struct from an io.Reader.
v8/config/krb5conf.go:535
↓ 1 callersFunctionNewInitiatorMICToken
NewInitiatorMICToken builds a new initiator token (acceptor flag will be set to 0) and computes the authenticated checksum. Other flags are set to 0.
gssapi/MICToken.go:162
↓ 1 callersFunctionNewInitiatorMICToken
NewInitiatorMICToken builds a new initiator token (acceptor flag will be set to 0) and computes the authenticated checksum. Other flags are set to 0.
v8/gssapi/MICToken.go:162
↓ 1 callersFunctionNewInitiatorWrapToken
NewInitiatorWrapToken builds a new initiator token (acceptor flag will be set to 0) and computes the authenticated checksum. Other flags are set to 0,
gssapi/wrapToken.go:175
↓ 1 callersFunctionNewInitiatorWrapToken
NewInitiatorWrapToken builds a new initiator token (acceptor flag will be set to 0) and computes the authenticated checksum. Other flags are set to 0,
v8/gssapi/wrapToken.go:175
↓ 1 callersFunctionNewNegTokenInitKRB5
NewNegTokenInitKRB5 creates new Init negotiation token for Kerberos 5
spnego/negotiationToken.go:289
↓ 1 callersFunctionNewNegTokenInitKRB5
NewNegTokenInitKRB5 creates new Init negotiation token for Kerberos 5
v8/spnego/negotiationToken.go:289
↓ 1 callersFunctionNewPrincipalName
NewPrincipalName creates a new PrincipalName from the name type int32 and name string provided.
types/PrincipalName.go:19
↓ 1 callersFunctionNewPrincipalName
NewPrincipalName creates a new PrincipalName from the name type int32 and name string provided.
v8/types/PrincipalName.go:19
↓ 1 callersFunctionNewSessionMgr
(cookieName string)
v8/spnego/http_test.go:409
↓ 1 callersFunctionNewSessionMgr
(cookieName string)
v8/examples/example-AD.go:133
↓ 1 callersFunctionNewSessionMgr
(cookieName string)
v8/examples/httpServer.go:75
↓ 1 callersFunctionOID
OID returns the OID for the provided OID name.
gssapi/gssapi.go:120
↓ 1 callersMethodPost
Post is the SPNEGO enabled HTTP client's equivalent of the http.Client's Post method.
spnego/http.go:128
↓ 1 callersMethodPost
Post is the SPNEGO enabled HTTP client's equivalent of the http.Client's Post method.
v8/spnego/http.go:135
↓ 1 callersMethodPrint
Print writes the details of the client to the io.Writer provided.
v8/client/client.go:311
↓ 1 callersMethodRandomToKey
RandomToKey returns a key from the bytes provided.
crypto/des3-cbc-sha1-kd.go:83
↓ 1 callersMethodRandomToKey
RandomToKey returns a key from the bytes provided.
v8/crypto/des3-cbc-sha1-kd.go:83
↓ 1 callersMethodRemoveEntry
RemoveEntry removes the cache entry for the defined SPN.
v8/client/cache.go:93
↓ 1 callersMethodRequireHostAddr
RequireHostAddr indicates if the service should require the host address to be included in the ticket.
service/settings.go:43
↓ 1 callersMethodRequireHostAddr
RequireHostAddr indicates if the service should require the host address to be included in the ticket.
v8/service/settings.go:45
↓ 1 callersFunctionS2KparamsToItertions
S2KparamsToItertions converts the string representation of iterations to an integer for RFC 8009.
crypto/rfc8009/keyDerivation.go:118
↓ 1 callersFunctionS2KparamsToItertions
S2KparamsToItertions converts the string representation of iterations to an integer
crypto/rfc3962/keyDerivation.go:37
↓ 1 callersFunctionS2KparamsToItertions
S2KparamsToItertions converts the string representation of iterations to an integer for RFC 8009.
v8/crypto/rfc8009/keyDerivation.go:119
↓ 1 callersFunctionS2KparamsToItertions
S2KparamsToItertions converts the string representation of iterations to an integer
v8/crypto/rfc3962/keyDerivation.go:37
↓ 1 callersFunctionSPNEGOClient
SPNEGOClient configures the SPNEGO mechanism suitable for client side use.
spnego/spnego.go:25
↓ 1 callersFunctionSPNEGOKRB5Authenticate
SPNEGOKRB5Authenticate is a Kerberos SPNEGO authentication HTTP handler wrapper.
spnego/http.go:218
↓ 1 callersMethodSessionID
SessionID returns the credential's session ID.
credentials/credentials.go:279
↓ 1 callersMethodSetAttribute
SetAttribute sets the value of an attribute.
credentials/credentials.go:302
↓ 1 callersMethodSetAttribute
SetAttribute sets the value of an attribute.
v8/credentials/credentials.go:318
↓ 1 callersMethodSetCheckSum
SetCheckSum uses the passed encryption key and key usage to compute the checksum over the payload and the header, and sets the CheckSum field of this
gssapi/wrapToken.go:72
↓ 1 callersMethodSetCheckSum
SetCheckSum uses the passed encryption key and key usage to compute the checksum over the payload and the header, and sets the CheckSum field of this
v8/gssapi/wrapToken.go:72
↓ 1 callersMethodSetChecksum
SetChecksum uses the passed encryption key and key usage to compute the checksum over the payload and the header, and sets the Checksum field of this
gssapi/MICToken.go:71
↓ 1 callersMethodSetChecksum
SetChecksum uses the passed encryption key and key usage to compute the checksum over the payload and the header, and sets the Checksum field of this
v8/gssapi/MICToken.go:71
↓ 1 callersMethodSetDisplayName
SetDisplayName sets the display name value on the credential.
credentials/credentials.go:198
↓ 1 callersMethodSetDisplayName
SetDisplayName sets the display name value on the credential.
v8/credentials/credentials.go:214
↓ 1 callersMethodSetDomain
SetDomain sets the domain value on the credential.
credentials/credentials.go:178
↓ 1 callersMethodSetDomain
SetDomain sets the domain value on the credential.
v8/credentials/credentials.go:194
↓ 1 callersMethodSetUserName
SetUserName sets the username value on the credential.
credentials/credentials.go:158
↓ 1 callersMethodSetUserName
SetUserName sets the username value on the credential.
v8/credentials/credentials.go:174
↓ 1 callersMethodSetValidUntil
SetValidUntil sets the expiry time of the credentials
credentials/credentials.go:132
↓ 1 callersMethodSetValidUntil
SetValidUntil sets the expiry time of the credentials
v8/credentials/credentials.go:140
↓ 1 callersFunctionStringToKey
StringToKey returns a key derived from the string provided according to the definition in RFC 4757.
crypto/rfc4757/keyDerivation.go:14
↓ 1 callersFunctionStringToKey
StringToKey returns a key derived from the string provided according to the definition in RFC 4757.
v8/crypto/rfc4757/keyDerivation.go:14
↓ 1 callersMethodStringToKey
StringToKey returns a key derived from the string provided.
crypto/aes256-cts-hmac-sha384-192.go:72
↓ 1 callersMethodStringToKey
StringToKey returns a key derived from the string provided.
crypto/des3-cbc-sha1-kd.go:75
↓ 1 callersMethodStringToKey
StringToKey returns a key derived from the string provided.
crypto/aes256-cts-hmac-sha1-96.go:73
↓ 1 callersMethodStringToKey
StringToKey returns a key derived from the string provided.
crypto/aes128-cts-hmac-sha256-128.go:72
↓ 1 callersMethodStringToKey
StringToKey returns a key derived from the string provided.
crypto/aes128-cts-hmac-sha1-96.go:73
↓ 1 callersMethodStringToKey
StringToKey returns a key derived from the string provided.
v8/crypto/aes256-cts-hmac-sha384-192.go:72
↓ 1 callersMethodStringToKey
StringToKey returns a key derived from the string provided.
v8/crypto/des3-cbc-sha1-kd.go:75
↓ 1 callersMethodStringToKey
StringToKey returns a key derived from the string provided.
v8/crypto/aes256-cts-hmac-sha1-96.go:73
↓ 1 callersMethodStringToKey
StringToKey returns a key derived from the string provided.
v8/crypto/aes128-cts-hmac-sha256-128.go:72
↓ 1 callersMethodStringToKey
StringToKey returns a key derived from the string provided.
v8/crypto/aes128-cts-hmac-sha1-96.go:73
↓ 1 callersFunctionStringToKeyIter
StringToKeyIter returns a key derived from the string provided according to the definition in RFC 8009.
crypto/rfc8009/keyDerivation.go:75
↓ 1 callersFunctionStringToKeyIter
StringToKeyIter returns a key derived from the string provided according to the definition in RFC 3961.
crypto/rfc3962/keyDerivation.go:31
↓ 1 callersFunctionStringToKeyIter
StringToKeyIter returns a key derived from the string provided according to the definition in RFC 8009.
v8/crypto/rfc8009/keyDerivation.go:76
↓ 1 callersFunctionStringToKeyIter
StringToKeyIter returns a key derived from the string provided according to the definition in RFC 3961.
v8/crypto/rfc3962/keyDerivation.go:31
↓ 1 callersFunctionStringToPBKDF2
StringToPBKDF2 generates an encryption key from a pass phrase and salt string using the PBKDF2 function from PKCS #5 v2.0
crypto/rfc8009/keyDerivation.go:81
↓ 1 callersFunctionStringToPBKDF2
StringToPBKDF2 generates an encryption key from a pass phrase and salt string using the PBKDF2 function from PKCS #5 v2.0
crypto/rfc3962/keyDerivation.go:26
↓ 1 callersFunctionStringToPBKDF2
StringToPBKDF2 generates an encryption key from a pass phrase and salt string using the PBKDF2 function from PKCS #5 v2.0
v8/crypto/rfc8009/keyDerivation.go:82
↓ 1 callersFunctionStringToPBKDF2
StringToPBKDF2 generates an encryption key from a pass phrase and salt string using the PBKDF2 function from PKCS #5 v2.0
v8/crypto/rfc3962/keyDerivation.go:26
↓ 1 callersMethodTGSExchange
TGSExchange exchanges the provided TGS_REQ with the KDC to retrieve a TGS_REP. Referrals are automatically handled. The client's cache is updated with
client/TGSExchange.go:23
↓ 1 callersMethodTGSExchange
TGSExchange exchanges the provided TGS_REQ with the KDC to retrieve a TGS_REP. Referrals are automatically handled. The client's cache is updated with
v8/client/TGSExchange.go:23
↓ 1 callersMethodUnmarshal
Unmarshal bytes into the TypedDataSequence.
types/TypedData.go:15
↓ 1 callersMethodUnmarshal
Unmarshal bytes into the EncryptionKey.
types/Cryptosystem.go:46
↓ 1 callersMethodUnmarshal
Unmarshal bytes into the PAReqEncPARep
types/PAData.go:96
↓ 1 callersMethodUnmarshal
Unmarshal bytes into the ADKDCIssued.
types/AuthorizationData.go:40
↓ 1 callersMethodUnmarshal
Unmarshal a KRB5Token.
spnego/krb5Token.go:67
↓ 1 callersMethodUnmarshal
Unmarshal bytes into the TypedDataSequence.
v8/types/TypedData.go:15
↓ 1 callersMethodUnmarshal
Unmarshal bytes into the EncryptionKey.
v8/types/Cryptosystem.go:49
↓ 1 callersMethodUnmarshal
Unmarshal bytes into the PAReqEncPARep
v8/types/PAData.go:96
↓ 1 callersMethodUnmarshal
Unmarshal bytes into the ADKDCIssued.
v8/types/AuthorizationData.go:40
↓ 1 callersMethodUnmarshal
Unmarshal an Init negotiation token
v8/spnego/negotiationToken.go:92
↓ 1 callersMethodUnmarshal
Unmarshal bytes b into the KRBCred struct.
v8/messages/KRBCred.go:58
↓ 1 callersMethodUnmarshal
Unmarshal bytes b into the APRep struct.
v8/messages/APRep.go:30
↓ 1 callersMethodUnmarshal
Unmarshal a byte slice into a Reply.
v8/kadmin/message.go:70
↓ 1 callersMethodUnmarshal
Unmarshal bytes into the UPN_DNSInfo struct
v8/pac/upn_dns_info.go:25
↓ 1 callersMethodUnmarshal
Unmarshal bytes into the ClientInfo struct
v8/pac/client_info.go:17
↓ 1 callersMethodUnmarshal
Unmarshal bytes b into the KRBCred struct.
messages/KRBCred.go:58
↓ 1 callersMethodUnmarshal
Unmarshal bytes b into the APRep struct.
messages/APRep.go:30
↓ 1 callersMethodUnmarshal
Unmarshal a byte slice into a Reply.
kadmin/message.go:70
↓ 1 callersMethodUnmarshal
Unmarshal bytes into the UPN_DNSInfo struct
pac/upn_dns_info.go:25
↓ 1 callersMethodUnmarshal
Unmarshal bytes into the ClientInfo struct
pac/client_info.go:17
↓ 1 callersMethodValid
Valid checks it the ticket is currently valid. Max duration passed endtime passed in as argument.
v8/messages/Ticket.go:249
↓ 1 callersMethodValid
Valid checks it the ticket is currently valid. Max duration passed endtime passed in as argument.
messages/Ticket.go:252
↓ 1 callersMethodVerify
Verify checks the validity of AS_REP message.
v8/messages/KDCRep.go:248
↓ 1 callersMethodVerify
Verify checks the validity of the TGS_REP message.
v8/messages/KDCRep.go:320
↓ 1 callersMethodVerify
Verify checks the validity of AS_REP message.
messages/KDCRep.go:181
↓ 1 callersMethodVerify
Verify checks the validity of the TGS_REP message.
messages/KDCRep.go:263
↓ 1 callersFunctionVerifyIntegrity
VerifyIntegrity checks the integrity checksum of the data matches that calculated from the decrypted data.
crypto/rfc4757/encryption.go:77
↓ 1 callersFunctionVerifyIntegrity
VerifyIntegrity checks the integrity checksum of the data matches that calculated from the decrypted data.
v8/crypto/rfc4757/encryption.go:77
↓ 1 callersMethodVerifyIntegrity
VerifyIntegrity checks the integrity of the ciphertext message. As the hash is calculated over the iv concatenated with the AES cipher output not the
crypto/aes256-cts-hmac-sha384-192.go:115
↓ 1 callersMethodVerifyIntegrity
VerifyIntegrity checks the integrity of the ciphertext message. As the hash is calculated over the iv concatenated with the AES cipher output not the
crypto/aes128-cts-hmac-sha256-128.go:115
↓ 1 callersMethodVerifyIntegrity
VerifyIntegrity checks the integrity of the ciphertext message. As the hash is calculated over the iv concatenated with the AES cipher output not the
v8/crypto/aes256-cts-hmac-sha384-192.go:115
↓ 1 callersMethodVerifyIntegrity
VerifyIntegrity checks the integrity of the ciphertext message. As the hash is calculated over the iv concatenated with the AES cipher output not the
v8/crypto/aes128-cts-hmac-sha256-128.go:115
↓ 1 callersMethodaddMapping
Add a domain to realm mapping.
v8/config/krb5conf.go:487
↓ 1 callersMethodaddMapping
Add a domain to realm mapping.
config/krb5conf.go:488
↓ 1 callersMethodclear
clear deletes all the cache entries
client/cache.go:60
← previousnext →601–700 of 1,776, ranked by callers