MCPcopy Create free account

hub / github.com/NLnetLabs/domain / functions

Functions4,465 in github.com/NLnetLabs/domain

↓ 1 callersMethodis_async
(&self)
examples/other/mysql-zone.rs:245
↓ 1 callersMethodis_compressed
Returns whether the name is compressed.
src/base/name/parsed.rs:73
↓ 1 callersFunctionis_dnssec
Check if a type is a DNSSEC type that needs to be removed.
src/net/client/validator.rs:589
↓ 1 callersMethodis_dnssec_ok
Whether the client supports DNSSEC. See [RFC 3225](https://datatracker.ietf.org/doc/html/rfc3225).
src/new/edns/mod.rs:332
↓ 1 callersMethodis_empty
Whether the [`CharStr`] is empty.
src/new/base/charstr.rs:72
↓ 1 callersMethodis_empty
Returns true if there are no errors.
src/zonetree/error.rs:200
↓ 1 callersMethodis_empty
Returns whether the name is still empty.
src/base/name/builder.rs:141
↓ 1 callersMethodis_error
Returns whether the rcode of the header is one of the error values.
src/base/message.rs:316
↓ 1 callersMethodis_ext
(&self)
src/base/iana/rcode.rs:567
↓ 1 callersMethodis_label_start
Returns whether an index points to the first octet of a label.
src/base/name/relative.rs:418
↓ 1 callersMethodis_label_start
Returns whether an index points to the first byte of a non-root label.
src/base/name/absolute.rs:456
↓ 1 callersFunctionis_ord
(l: &[u8], r: &[u8], order: cmp::Ordering)
src/base/charstr.rs:1312
↓ 1 callersMethodis_revoked
Returns whether the Revoke flag is set. See [RFC 5011, Section 3]. [RFC 5011, Section 3]: https://tools.ietf.org/html/rfc5011#section-3
src/rdata/dnssec.rs:150
↓ 1 callersMethodis_root
Whether this is the root label.
src/new/base/name/unparsed.rs:82
↓ 1 callersMethodis_secure_entry_point
Whether external entities are expected to point to this key.
src/new/rdata/dnssec/dnskey.rs:169
↓ 1 callersMethodis_secure_entry_point
Returns whether the the Secure Entry Point (SEP) flag is set. See [RFC 4034, Section 2.1.1]: > This flag is only intended to be a hint to zone signi
src/rdata/dnssec.rs:164
↓ 1 callersMethodis_shutdown
Check if shutdown has completed. Note that until shutdown is fully complete some Tokio background tasks may remain scheduled or active to process in-
src/net/server/stream.rs:477
↓ 1 callersMethodis_shutdown
Check if shutdown has completed. Note that until shutdown is fully complete some Tokio background tasks may remain scheduled or active to process in-
src/net/server/dgram.rs:432
↓ 1 callersMethodis_stream
Report whether in stream mode or not.
src/net/client/stream.rs:454
↓ 1 callersMethodis_wildcard
(&self)
src/base/name/label.rs:335
↓ 1 callersMethodis_xfr
Returns whether the message has a question that is either AXFR or IXFR.
src/base/message.rs:445
↓ 1 callersMethodis_zone_key
Whether this key is used for signing DNS records.
src/new/rdata/dnssec/dnskey.rs:159
↓ 1 callersMethoditer
An iterator over the anchor's records.
src/dnssec/validator/anchor.rs:74
↓ 1 callersMethoditer
Return an iterator for TypeBitmaps
src/new/rdata/dnssec/nsec.rs:227
↓ 1 callersMethoditer
Returns an iterator over the records in the message. The iterator’s item is a pair of a [`ParsedRecord`] and the [`Section`] it was found in. As is
src/base/message.rs:415
↓ 1 callersMethoditer
Returns an iterator over the IP addresses returned by the lookup.
src/resolv/lookup/host.rs:136
↓ 1 callersMethoditer_labels
(&self)
src/base/name/parsed.rs:463
↓ 1 callersFunctioniter_slice
()
src/base/name/label.rs:1040
↓ 1 callersMethoditer_zones
Returns an iterator over all of the [`Zone`]s in the tree.
src/zonetree/tree.rs:65
↓ 1 callersMethodkeys
Get the DNSKEYs.
src/dnssec/validator/context.rs:1668
↓ 1 callersMethodlabel_count
Returns the number of labels in the name.
src/base/name/relative.rs:381
↓ 1 callersMethodlimit_ttl
Limits the TTL of every record in the RRSet. If the TTL currently exceeds the given limit it will be set to the limit.
src/zonetree/types.rs:146
↓ 1 callersFunctionlookup_addr
Resolves the host names of an IP address. The function will query DNS using the resolver represented by `resolv`. It will query DNS only and not cons
src/resolv/lookup/addr.rs:26
↓ 1 callersMethodlookup_addr
( &self, addr: IpAddr, )
src/resolv/stub/mod.rs:230
↓ 1 callersMethodlookup_entry_for_name
Look up entries which share a suffix with the given name. At most one entry ends with a complete label matching the given name. We will carefully mat
src/new/base/name/compressor.rs:344
↓ 1 callersMethodlookup_entry_for_revname
Look up entries which share a suffix with the given reversed name. At most one entry ends with a complete label matching the given name. We will matc
src/new/base/name/compressor.rs:191
↓ 1 callersFunctionlookup_srv
Creates a future that looks up SRV records. The future will use the resolver given in `resolver` to query the DNS for SRV records associated with dom
src/resolv/lookup/srv.rs:66
↓ 1 callersMethodmake_canonical
Converts the name into its canonical form.
src/base/name/relative.rs:296
↓ 1 callersMethodmake_canonical
Converts the domain name into its canonical form. This will convert all octets that are upper case ASCII characters into their lower case equivalent.
src/base/name/absolute.rs:370
↓ 1 callersFunctionmake_first_axfr
(request: &TestMessage)
tests/interop.rs:369
↓ 1 callersFunctionmake_last_axfr
(request: &TestMessage)
tests/interop.rs:388
↓ 1 callersFunctionmake_middle_axfr
( request: &TestMessage, one: u8, two: u8, )
tests/interop.rs:377
↓ 1 callersMethodmake_regular
(&self)
src/zonetree/in_memory/write.rs:591
↓ 1 callersMethodmap_name
Map the domain name within to another type.
src/new/rdata/basic/ns.rs:123
↓ 1 callersMethodmap_name_by_ref
Map a reference to the domain name within to another type.
src/new/rdata/basic/ns.rs:130
↓ 1 callersMethodmatch_additional
Match the additional section if `matches.additional` is set
src/stelline/matches.rs:336
↓ 1 callersMethodmatch_any_answer
Match any one of the available answers (additional answers can be provided using the EXTRA_PACKET Stelline directive).
src/stelline/matches.rs:307
↓ 1 callersMethodmatch_authority
Match the authority section if `matches.authority` is set
src/stelline/matches.rs:320
↓ 1 callersMethodmatch_edns_data
Match the ENDS data in the OPT record
src/stelline/matches.rs:83
↓ 1 callersMethodmatch_flags
Match the flags of the incoming message including `DO`
src/stelline/matches.rs:358
↓ 1 callersMethodmatch_multi_msg_ordered
(&self)
src/stelline/matches.rs:32
↓ 1 callersMethodmatch_multi_msg_unordered
(&self)
src/stelline/matches.rs:39
↓ 1 callersMethodmatch_opcode
Match the value of the OPCODE
src/stelline/matches.rs:105
↓ 1 callersMethodmatch_question
Match the question section This checks the qname, qtype and subdomain of the records in the section (if the relevant fields of `Matches` are set).
src/stelline/matches.rs:157
↓ 1 callersMethodmatch_rcode
Match the value of the RCODE
src/stelline/matches.rs:134
↓ 1 callersMethodmax_bad_signatures
Return the value of max_bad_signatures.
src/dnssec/validator/context.rs:236
↓ 1 callersMethodmax_bogus_validity
Return the value of max_bogus_validity.
src/dnssec/validator/context.rs:223
↓ 1 callersMethodmax_cname_dname
Return the value of max_cname_dname.
src/dnssec/validator/context.rs:277
↓ 1 callersMethodmax_concurrent_connections
Gets the configured maximum number of concurrent connections.
src/net/server/stream.rs:138
↓ 1 callersMethodmax_ttl
Return the maximum TTL in a group. Include not only the rr_set but also sig_set and extra.set. This TTL is used to determine if the original message
src/dnssec/validator/group.rs:706
↓ 1 callersFunctionmk_base32hex_label_for_name
( name: &N, alg: Nsec3HashAlgorithm, iterations: u16, salt: &Nsec3Salt<SaltOcts>, )
src/dnssec/sign/denial/nsec3.rs:739
↓ 1 callersFunctionmk_client_factory
( dgram_server_conn: ClientServerChannel, stream_server_conn: ClientServerChannel, key_store: Arc<
src/net/server/tests/integration.rs:265
↓ 1 callersFunctionmk_dnskey_rr
( name: &str, dnskey: &Dnskey<Bytes>, )
src/dnssec/sign/signatures/rrsigs.rs:1176
↓ 1 callersFunctionmk_first_ixfr_response
( req: &Message<Bytes>, new_soa: &Soa<Name<Bytes>>, old_soa: Soa<Name<Bytes>>, )
src/net/xfr/protocol/tests.rs:533
↓ 1 callersFunctionmk_hash
Compute the hash octets.
src/dnssec/common.rs:127
↓ 1 callersFunctionmk_hashed_nsec3_owner_name
( name: &N, alg: Nsec3HashAlgorithm, iterations: u16, salt: &Nsec3Salt<SaltOcts>, apex_own
src/dnssec/sign/denial/nsec3.rs:701
↓ 1 callersFunctionmk_ixfr_request
( qname: impl ToName + Clone, serial: Serial, metadata: T, )
src/net/server/middleware/xfr/tests.rs:649
↓ 1 callersFunctionmk_nsec3
( name: &N, alg: Nsec3HashAlgorithm, flags: u8, iterations: u16, salt: &Nsec3Salt<Octs>,
src/dnssec/sign/denial/nsec3.rs:656
↓ 1 callersFunctionmk_nsec3param_rr
( owner: &str, cfg: &GenerateNsec3Config<Bytes, Sort>, )
src/dnssec/sign/test_util/mod.rs:112
↓ 1 callersFunctionmk_precalculated_nsec3_rr
( owner: &str, next_owner: &str, types: &str, cfg: &GenerateNsec3Config<Bytes, Sort>, )
src/dnssec/sign/test_util/mod.rs:175
↓ 1 callersFunctionmk_rfc_1995_ixfr_example_soa
( serial: u32, )
src/zonetree/update.rs:878
↓ 1 callersFunctionmk_second_ixfr_response
( req: Message<Bytes>, new_soa: Soa<Name<Bytes>>, )
src/net/xfr/protocol/tests.rs:550
↓ 1 callersFunctionmk_server_configs
( config: &ServerConfig<'_>, )
src/net/server/tests/integration.rs:378
↓ 1 callersFunctionmk_servers
( service: Svc, server_config: &ServerConfig<'_>, dgram_server_conn: ClientServerChannel, stre
src/net/server/tests/integration.rs:223
↓ 1 callersFunctionmk_soa_answer
( msg: &Request<Vec<u8>, ()>, builder: MessageBuilder<StreamTarget<Target>>, )
examples/server-transports.rs:71
↓ 1 callersFunctionmk_udp_axfr_request
( qname: impl ToName, metadata: T, )
src/net/server/middleware/xfr/tests.rs:623
↓ 1 callersMethodmove_redundant_cnames
Move CNAMEs that are associated with a DNAME to the extra part of the DNAME's group. Then remove the CNAME's group.
src/dnssec/validator/group.rs:766
↓ 1 callersMethodmoved_to_dname
Try to move a CNAME record to a matching DNAME group in the group set. Return true if a matching DNAME was found and the move happened.
src/dnssec/validator/group.rs:797
↓ 1 callersFunctionname_eq
(parsed: ParsedName<&[u8]>, name: ParsedName<&[u8]>)
src/base/name/parsed.rs:1021
↓ 1 callersFunctionne_step
(name: N)
src/base/name/parsed.rs:1182
↓ 1 callersFunctionnet_pubkey
Returns the current net KSK/ZSK for testing (1024b)
src/dnssec/validator/base.rs:376
↓ 1 callersMethodnew_conn
Request a new connection.
src/net/client/multi_stream.rs:162
↓ 1 callersMethodnew_lifetime_param
Generate a unique lifetime parameter with the given prefix and bounds.
macros/src/impls.rs:204
↓ 1 callersMethodnewline
(&mut self)
src/base/zonefile_fmt.rs:138
↓ 1 callersMethodnext
(&mut self)
src/new/rdata/edns.rs:374
↓ 1 callersMethodnext
(&mut self)
src/rdata/svcb/value.rs:579
↓ 1 callersMethodnext
(&mut self)
src/rdata/svcb/params.rs:581
↓ 1 callersMethodnext
(&mut self)
src/base/opt/mod.rs:843
↓ 1 callersMethodnext_back
(&mut self)
src/base/name/relative.rs:954
↓ 1 callersMethodnext_char_symbol
Returns the next symbol if it is unescaped. Returns `None` if the symbol is escaped or `self.next_symbol` would return `None`. If it returns `Some(_
src/zonefile/inplace.rs:1349
↓ 1 callersFunctionnext_line
Find the next non-blank line in the file.
src/dnssec/common.rs:178
↓ 1 callersMethodnext_no_escapes
An iterator but error on escape sequences
src/rdata/svcb/value.rs:2204
↓ 1 callersMethodnext_node
(&mut self)
src/zonetree/tree.rs:235
↓ 1 callersMethodnext_step
(&mut self)
src/rdata/svcb/params.rs:556
↓ 1 callersMethodnext_step
Returns the next item from the parser. Expects there to be another option available and will return a parse error otherwise. Return `Ok(None)` if the
src/base/opt/mod.rs:822
↓ 1 callersFunctionnormalize_prefix_len
Limits a prefix length for the given address.
src/base/opt/subnet.rs:359
↓ 1 callersMethodnotify_zone_changed
( &self, class: Class, apex_name: &Name<Bytes>, serial: Option<Serial>,
src/net/server/middleware/notify.rs:445
↓ 1 callersFunctionnsec3_for_ds
Find an NSEC3 record hat proves that a DS record does not exist and return the delegation status based on the rtypes present. NSEC3 processing is sim
src/dnssec/validator/context.rs:2008
↓ 1 callersFunctionnsec3_for_nodata_wildcard
Find a closest encloser target and then find an NSEC3 record for the wildcard that proves that no record that matches rtype exist.
src/dnssec/validator/nsec.rs:575
↓ 1 callersFunctionnsec3_for_nxdomain
Find a closest encloser for the target name and then find an NSEC3 record that proves that the wildcard does not exist.
src/dnssec/validator/nsec.rs:885
← previousnext →1,401–1,500 of 4,465, ranked by callers